Menu
Cart 0

Rhino 5 for Apple OS X

Rhino 5 for Apple Macintosh runs on ordinary AppleMac desktop and laptop computers, with:

  • Requires: OS X Mountain Lion (10.8.5), OS X Mavericks, or OS X Yosemite
  • Requires: 64-bit Core 2 Duo Intel processors or later
  • OS X 10.7 and below, 32-bit Intel, and PowerPC are NOT supported
  • A multiple-button mouse with scroll wheel is recommended.
  • The SpaceNavigator is supported.
     
  • The Spaceball and SpaceExplorer are not supported